Can not setGeo to EU

0 votes
Hi, According to the docs, I should be able to setGeo to EU or US. But, I can not. This is my code [[WarpClient getInstance]setRecoveryAllowance:60]; [[WarpClient getInstance] enableTrace:YES]; [[WarpClient getInstance] setGeo:@"EU"]; And here are the logs: AppWarp Version:2.1 AppWarpTrace: -[WarpClient connectWithUserName:]..connectionState=2 AppWarpTrace: -[WarpClient connectWithUserName:]..Doing look up AppWarpTrace: -[WarpClient lookUpForTheHostServer] AppWarpTrace: Geo=EU AppWarpTrace: urlString=https://control.appwarp.shephertz.com/lookup_dns?api=c03d1b9e0214b0d514f13ad2ee1ac800ffe0c26cd2bdc913a58c5b101e4b0a93&geo=EU AppWarpTrace: didReceiveResponse= { URL: https://control.appwarp.shephertz.com/lookup_dns?api=c03d1b9e0214b0d514f13ad2ee1ac800ffe0c26cd2bdc913a58c5b101e4b0a93&geo=EU } { Status Code: 404, Headers { AppWarpTrace: -[WarpClient connection:didReceiveData:]= { request: { URL: https://control.appwarp.shephertz.com/lookup_dns?api=c03d1b9e0214b0d514f13ad2ee1ac800ffe0c26cd2bdc913a58c5b101e4b0a93&geo=EU } } AppWarpTrace: -[WarpClient raiseConnectionListenerWithResult:]..result=5 AppWarpTrace: -[WarpClient connectionDidFinishLoading:]={ AppWarpTrace: -[WarpClient connectWithUserName:]..connectionState=2 AppWarpTrace: -[WarpClient connectWithUserName:]..Doing look up AppWarpTrace: -[WarpClient lookUpForTheHostServer] AppWarpTrace: Geo=EU This error goes for ever. Why is that? Thank you
asked Oct 3, 2019 in iOS by info (16 points)
I also tried to setGeo to "eu.appwarp.shephertz.com", but I got the same error message

2 Answers

0 votes

Hi Info,

Greetings!!!

Please use the below code:

[[WarpClient getInstance] setGeo:@"eu"];  at the place of [[WarpClient getInstance] setGeo:@"EU"]; 
 
In the case of any other concern please let us know, we will be happy to helo you.
 
Regards,
Priyanka Singh
App42 Team
 
answered Oct 4, 2019 by priyanka.singh (186 points)
0 votes

Hi Priyanka,

 

This does fix the problem. But, now I have a bigger problem

If I setGeo to "eu" or "japan", the method

- (void)onConnectDone:(ConnectEvent *)connectEvent

is never called

if I setGeo to "us" I can connect, subscribe to Lobby, get the list of available players, but, the method

- (void)onGetLiveUserInfoDone:(LiveUserInfoEvent *)event

is never called.

 

I am located in Europe, but I do not think that this matter at all.

Thank you

answered Oct 4, 2019 by info (16 points)
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com
...