0 votes
When I attempt to connect to the AppWarp server, I always get the error  "CONNECTION_ERR" =5. Why? 
The secret key and the API key are right and the initialization is done. 
Thank you very much
asked Mar 10, 2014 in AppWarp by lon2 (10 points)

1 Answer

0 votes
Can you give some more details? - like what platform you are using.. which SDK you are using etc.
answered Mar 10, 2014 by dhruvc (1,099 points)
I am using Eclipse with the Android Developer Tools, sdk 7
Have you added internet permission in your manifest?
yes android.permission.INTERNET and android.permission.ACCESS_NETWORK_STATE
Can you confirm that the app you created is of type 'Warp'? as mentioned in the below link
yes, it's an app with App Cloud API Warp, and I also created a test room. The connection error is when I try to connect with a username
Hmm.. After initialize - can you add WarpClient.enableTrace(true);
This will print some additional logs that might be useful. Also have you tried one of our Android samples? Are you getting the same issue with them as well?
AppWarpTrace says: AppWarpTrace :1394478620747:Exception in disconnect closing the channel java.lang.NullPointerException
I tried with the example "Fruity Monster", this time it gives error: RESOURCE_NOT_FOUND = 2, I modified my code, he responds with RESOURCE_NOT_FOUND

Now If I connect with a wrong API key and private key, I always get the error RESOURCE_NOT_FOUND instead of AUTH_ERROR = 1;
I tried it with another device by installing the test app and the connection works .. it is really strange!  I do not know why it happens. Maybe there are device requirements for using  this api?
The SDK works on all android devices. Which Api (repsonse listener) is giving you Resource_not_found?
Do note that if you try to join with the same name from two or more devices - you will get auth_error. Connected users need to have unique usernames.
It is  Connection Request Listener
You should connect with the correct keys. Resource not found is if your app key is incorrect i.e. an application doesn't exist on our cloud for the key given. Authentication error will come if the api key is correct (application exists) but either the secret key is incorrect OR if another user with the same name is already connected.

If the issue is persisting - please send us a mail on with your keys and we can look in to it if there is something wrong specific to your application container. Also you can send us any modifications to that sample that you may have done.
No, the problem is just the device, even trying with one of your examples. Perhaps the device is too old or incompatible with some features .. because with a smartphone the application connects, the ConnectionRequestListener responds correctly, so the keys are right and all the rest.

it is strange, as well as to change the device, I do not know what I could do.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on