Custom Code compile exception

0 votes
Version : 1.10

Hi,

I've downloaded the custom code sample and imported it into Eclipse. 

Since the code may not have copiled with Java 8, I also added the 7 JDK and selected it as my default java version.

Now the issue is when I try to compile and run the sample code (no additions done), I get the error "Exception in thread "main" java.lang.Exception: Please provide required arguments...apikey, secretkey, name, action at com.myapp.helper.AntHelper.main(AntHelper.java:27)"

All these parameters exist in the build.proprties file, so why does it still not compile? Is it the Java version?

 

 
asked Jul 21 in Java by mariam.d (10 points)

2 Answers

0 votes
Hello Mariam,

Custom Code works with Java 7 as of now and that was the reason it did not compile when you tried using Java 8.

Please let me know if you have any further query, I will be happy to help you.

Thanks.
answered Jul 24 by rajeev.etc (1,498 points)
Hi Rajeev,

I have Java 7 & 8 both installed. But for compiling I have set the SDK version to 7.
The error still occurs.
Do I need to uninstall JDK 8?

Thanks,
Mariam
0 votes
Hello Mariam,

 

It seems like you are trying to run the sample code from the command line and you have not provided your keys in build.properties file. So, Could you please verify and let me know if it solves your issue.

 

Regards,

Himanshu Sharma
answered Jul 24 by hs00105 (1,935 points)
Hi Himanshu,

I have entered the key and secret in the build.properties.
I've not made any other alteration to the code. I'm running the sample code just as it is. I still get the error.

Mariam
Hi Mariam,

In that case, please share the source code and the steps which you have followed. It will help us to provide better support to you.

Regards,
Himanshu Sharma
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com
Migrate from Parse to ShepHertz App42
...