problem in dates sending php getTopNRankers and getRankersByDate

0 votes
Version : 2.6

Good morning,

Please help me find out why my query to server works wrong.

I use php-library in order to do a cronjob and to change scores to 0, every day, every week and every month at 00:15:10 GMT. Queries worked fine from 18th of September till today. But today I got this error:

Fatal error: Uncaught App42NotFoundException: Scores betweem startDate 'Fri Sep 26 15:06:38 UTC 4910' and endDate 'Tue Sep 26 20:00:00 UTC 2017' for the game with the name 'Looney Earth Daily' does not exist. in /home/c5ja7ybj/wp_looneyinvaders_dev3/wp-content/plugins/Featchapp_data/App24/RestClient.class.php:431 Stack trace: #0 /home/c5ja7ybj/wp_looneyinvaders_dev3/wp-content/plugins/Featchapp_data/App24/ScoreBoardService.php(653): RestClient::get('1.0/game/scoreb...', NULL, NULL, NULL, 'application/jso...', 'application/jso...', Array) #1 /home/c5ja7ybj/wp_looneyinvaders_dev3/wp-content/themes/elision-child/forCRON/earthdaily.php(78): ScoreBoardService->getTopNRankers('Looney Earth Da...', 1506298510, 1506384910, 2000) #2 /home/c5ja7ybj/wp_looneyinvaders_dev3/wp-content/themes/elision-child/forCRON/earthdaily.php(123): AppService->getRankersByDate('Looney Earth Da...', 1506298510, 1506384910) #3 {main} thrown in /home/c5ja7ybj/wp_looneyinvaders_dev3/wp-content/plugins/Featchapp_data/App24/RestClient.class.php on line 431

I checked timestamps in unix format. They are fine, but the dates which came back from server are completely wrong? What was wrong this time? Why queries worked nice more than week and today they broke out? Thank you

I also send you a log-file, may be it would help you...

 

asked Sep 26 in PHP by tomislav (17 points)

1 Answer

0 votes

Hi Tomislav,

Greetings!!!

We have forwarded your query to our team, we will be getting back to you as soon as possible.

Meanwhile, could you please share your code snippet in which you are getting these error with us on( support@shephertz.com ) ? It will help us to provide better support to you from our end.

 

Regards,

Priyanka Singh

App42 Team

answered Sep 26 by priyanka.singh (79 points)
Hi Tomislav,

Greetings!!!

We have checked this issues at our end it seems everything is working fine here. Could please share your app name and also add us ( collaborator@shephertz.com ) as a collaborator into your app in AppHQ? So, we can check the same in your app and it will help us to provide better support to you from our end.

Please follow the below steps for adding us as a collaborator:

App42 Cloud API->App Manager->Collaborator->Add Collaborator->Enter the above Email-ID and submit
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com
Migrate from Parse to ShepHertz App42
...