Unable To Receive e-mail Through Email Services.

0 votes

Configured Email services succesfully, and send e-mail successfully too (Got Success callback), but recevier did not get mail. Please guide me to make this working. Thanks in advance. Here is my Configure and Send email code snippet i.e

1.Configure:-

void AppManager::configureEmailServiceRequest(){

    string emailHost = "smtp.gmail.com";

    int emailPort = 465;

    string emailId = "MyEmail";

    string password = "Mypassword";

    bool isSSL = true;

    

    App42API::Initialize(APPWARP_APP_KEY, APPWARP_SECRET_KEY);

    EmailService *emailService = App42API::BuildEmailService();

    emailService->createMailConfiguration(emailHost.c_str(), emailPort, emailId.c_str(), password.c_str(), isSSL, app42callback(AppManager::onConfigureEmailServiceRequest, this));

   }

 

2.Send:-

void AppManager::sendEmailTo(string to, string sender, string subject, string message){

    EmailMIME emailMime = PLAIN_TEXT_MIME_TYPE;

    App42API::Initialize(APPWARP_APP_KEY, APPWARP_SECRET_KEY);

    EmailService *emailService = App42API::BuildEmailService();

    emailService->sendMail(to.c_str(), subject.c_str(), message.c_str(),sender.c_str(),emailMime,app42callback(AppManager::onSendEmail, this));

}

asked Nov 21, 2017 in Cocos2D-X by dbansal (11 points)

1 Answer

–1 vote

Hello,

Greetings!!!

Could you please set the port no. 587 instead 465 in your email configuration setting? and let us know if you are still facing this issue.

We will be happy to help you.

 

Regards,

Priyanka Singh

App42 Team

answered Nov 22, 2017 by priyanka.singh (186 points)
Hi Priyanka Thanks for reply. But it  still not working.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com
...