Room join failed (Soccer_Demo)

0 votes


I'm testing whether to use AppWarp to handle multiplayer for our iOS game.  I've created an account, created an app in the dashboard and added a room to it.

I downloaded the Soccer_Demo from gitHub and added the keys and room ID.  It builds and runs OK (both in the simulator and on a device) but after entering a name and clicking the start button it failed to connect to the room.  Specifically I get:

Join Zone done

Then a bunch of cocos2D stuff... then:

Room Join failed
subscribed failed

I've double checked the keys and room ID are entered correctly (in GlobalContext.m)

What am I doing wrong?  What should I try next?




I have now also tried the Fight Ninja sample with slightly more success but not a lot...

That one compiles and runs, and after entering a name I see that it connects with the following messages in the console:

.onJoinRoomDone..on Join room listener called Success

onSubscribeRoomDone  SUCCESS

but immediately after that it crashes every time with:

-[WarpResponse updateType]: unrecognized selector sent to instance 0x133a6bc0

Again I've not modified anything other than the config settings for the keys etc.  Any suggestions/advice would be most welcome.

asked May 16, 2014 in AppWarp by Bill Deakin (10 points)
edited May 16, 2014 by Bill Deakin

1 Answer

0 votes

We have tested the Fight Ninja sample and it is runing fine on both simulator as well as device.

Can you provide some more info like:

-Appwarp SDK version

-iOS version

-Crash log

answered May 19, 2014 by rajeev.etc (1,660 points)

Thanks for your response.  To answer your questions:

- The SDK version is whatever one is included in the project repository on GitHub here:

I just cloned the whole project.  I've just looked through the header files in AppWarp_iOS_SKD.framework but I can't see a version number anywhere.

- Testing in the simulator (7.1) I get the following output after the message for onSubscribeRoomDone SUCCESS:

2014-05-19 12:20:54.810 Fight Ninja[77711:60b] -[WarpResponse updateType]: unrecognized selector sent to instance 0xace7400
2014-05-19 12:20:54.812 Fight Ninja[77711:60b] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[WarpResponse updateType]: unrecognized selector sent to instance 0xace7400'
*** First throw call stack:
    0   CoreFoundation                      0x02e3c1e4 __exceptionPreprocess + 180
    1   libobjc.A.dylib                     0x022948e5 objc_exception_throw + 44
    2   CoreFoundation                      0x02ed9243 -[NSObject(NSObject) doesNotRecognizeSelector:] + 275
    3   CoreFoundation                      0x02e2c50b ___forwarding___ + 1019
    4   CoreFoundation                      0x02e2c0ee _CF_forwarding_prep_0 + 14
    5   Fight Ninja                         0x0016c388 -[WarpClient onNotify:] + 180
    6   Fight Ninja                         0x00165d35 -[ClientChannel onUdpSocket:didReceiveData:withTag:fromHost:port:] + 93
    7   Fight Ninja                         0x001796fe -[AsyncUdpSocket maybeCompleteCurrentReceive] + 165
    8   Fight Ninja                         0x00179610 -[AsyncUdpSocket doReceive:] + 1271
    9   Fight Ninja                         0x00179962 -[AsyncUdpSocket doCFSocketCallback:forSocket:withAddress:withData:] + 140
    10  Fight Ninja                         0x001748ce MyCFSocketCallback + 70
    11  CoreFoundation                      0x02dfc0da __CFSocketPerformV0 + 714
    12  CoreFoundation                      0x02dc577f __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 15
    13  CoreFoundation                      0x02dc51d5 __CFRunLoopDoSources0 + 437
    14  CoreFoundation                      0x02de21ae __CFRunLoopRun + 910
    15  CoreFoundation                      0x02de19d3 CFRunLoopRunSpecific + 467
    16  CoreFoundation                      0x02de17eb CFRunLoopRunInMode + 123
    17  GraphicsServices                    0x03dc65ee GSEventRunModal + 192
    18  GraphicsServices                    0x03dc642b GSEventRun + 104
    19  UIKit                               0x00d43f9b UIApplicationMain + 1225
    20  Fight Ninja                         0x000dbf26 main + 134
    21  Fight Ninja                         0x00002a65 start + 53
libc++abi.dylib: terminating with uncaught exception of type NSException

I get the same error if I test on an actual device (iOS 7.1 again)

I've not modified any of the project files other than to set the keys etc. in GameConstants.h

Any ideas?

Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on