Error accessing MySQL even after binding

0 votes


I have created a MySQL service on App42 PaaS and wanted to access it from an app running on my local machine. I executed the bindIP command but still not able to access it from my app. I also tried opening the connection using mysql client, but it is giving me the below error.


Can’t connect to MySQL Server on ‘X.X.X.X’


asked Mar 9, 2014 in App42PaaS & BPaaS by Frances Campoy (10 points)

1 Answer

+1 vote
Hi Frances,

There might be 2 reasons if you are not able to connect to MySQL service even after binding IP.

First, IP provided by you is not accessible from outside ie it is not the static/public IP. If you are running behind the firewall then the static IP is different from your machine IP. In that case, your machine IP would not work, you need to provide the static IP which you can obtain by running

Second, while connecting to MySQL from your local machine, you need to use the Public IP instead of VM IP as explained in the below post
answered Mar 9, 2014 by NaveenGShephertz (244 points)
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on