Problem in Setup AppWarpS2 in a Server Machine

0 votes

Recently I started using the AppWarpS2 Service. I followed the ChatServer application demo tutorial and successfully setup the AppWarpS2 server on my Local Machine using the ip address Now I have a server machine on Amazon Ec2 and I tried the same procedure to setup the chat server. This time I setup the server with my server machine public ip address. And I am able to connect a client from that same server PC, but i cant connect a client from my own local PC.

I have repeated the procedure to solve the problem but cant find what is going on. Here are the several info that could help to solve my problem-

1. Server PC is WIN-64 bit

2. It has all TCP and UDP Port Open

3. I have tried to setup the server with server pc DNS address but still no result

4. I can ping with the server pc from my local pc.

5. I am runnning the appWarpS2 server from eclips directly (that cant be the issue, can it?)

6. Latest version of jdk is installed.



asked Oct 21, 2014 in AppWarpS2 by apratim.056 (28 points)
edited Oct 21, 2014 by apratim.056

1 Answer

0 votes

Since you are able to ping your public IP address and port 12346, it seems your server is working fine and ports are open as well in EC2 security group. Therefore, there can be one possibility that you might have left IP address as in your client project by mistake.

Can you please recheck that you have also updated the IP address in your client application.

answered Oct 21, 2014 by Suyash Mohan (900 points)
Didn't find it anywhere. I thought i only have to change the app key in the client application (i.e. index.html file in the chatHTML5 client folder.) Also i cant login to the dashboard from my local pc, but i can login from the server pc.
In index.html, at line 138, you will find the initialization code. There we have used "localhost" as the host name. Replace it with the public IP address of your EC2 instance. Similarly to access the dashboard use your EC2's IP address in host field.
I have missed that part. Now changed it but the result is same and the client from my pc can not connect. And for login to dashboard I did put the server ip address earlier but it didnt work from my local pc.
One small info, instead of using the server pc public ip address i am using the server DNS address. Because if i use ip I cant login to dashboard from my server pc also, but the client works fine (even after I have changed the local host to the correct DNS address).
If domain name works for you instead of IP address you can use it too. To access dashboard from EC2 instance you will need to host it first. Install Apache HTTP server. Appwarp S2 Dashboard is a web application. You can also install it on localhost too and then use it to connect to AppWarpS2 server.
After 2 days of long search I finally figure out the problem. It was the server PC's firewall that was blocking my connection. Really silly, but i missed to check that. Thanks for your support. Now my server is ok, and running fine :D
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on