Can't seem to get AppWarpS2 Unity Android (using RPCs) working with Amazon Web Services (AWS)?

0 votes
I’m trying to get my mobile Android Unity game working with AppWarpS2 and a remote Amazon Web Services (AWS) Linux server.
I have been able to run the AppWarpS2 server on the Linux AWS instance and I successfully connected a PC executable version of the Unity game (using 'AppWarpS2Unity_1.0.8.dll') to the AppWarpS2 AWS server. I have the AppWarp admin dashboard working on the server as well.
Unfortunately when I run the game on an Android mobile device (using 'AppWarpS2UnityMobile_1.0.8.dll') I have not been able to connect the Unity game to the AWS server. Note that I have been able to get the Unity game working on the Android device when I host and target the AppWarpS2 server on my local PC ( but it stops working when I point it to the AWS Linux AppWarpS2 server?
I have configured the client side appWarp Unity software as follows;

private string appKey = "xxxxxxxx-xxxx-xxxx-x";

private string ipAddress = "";
private int port = 12346;
void Start () {
WarpClient.initialize(appKey, ipAddress, port);
listen = GetComponent<Listener>();
WarpClient.GetInstance().Connect("username", "");
void Update () {

For reference;

1. When targetting the mobile device I have been using the '' plugin and the 'AppWarpS2UnityMobile_1.0.8.dll' [which unlike other dlls requires me to specify a 'port' when initializing the client].

2. During testing I configured the AWS server to allow ‘All traffic’.

3. I use Remote Procedure Calls (RPCs) in my Unity game [which from what I've found restricts me to using certain versions of the AppWarpS2 unity dlls].
4. I've also tried different connection parameters; e.g. WarpClient.GetInstance().Connect("username", "test");
5. I'm using the free version of Unity.
I’ve spent the last week or so experimenting with different versions of the dlls and trying to pass different parameters to try and get this working but can't seem to find a solution - any help with this would be really appreciated.
Many thanks!
asked Feb 1, 2015 in AppWarpS2 by adamjgooch (10 points)
edited Feb 2, 2015 by adamjgooch

1 Answer

0 votes

You will need to use IP address of your Amazon EC2 instance instead of DNS. The issue only occurs in mobile devices because the plugin written for Android and iOS can only accept IP address.

answered Feb 2, 2015 by Suyash Mohan (900 points)
Yep, that's fixed it!! So simple...

Thanks very much, much appreciated!
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on