error testing push notification using appmethod / xe7

0 votes
i tried the example given here...

but encountered an error upon activating the control.

The error message is ...

"Device Token Request Failed

Access violation at address 7A216688, accessing address 0000000D"

Anybody managed to run the example successfully?

My Kinvey example ran fine. The App42Provider1 control + keys had been used / changed accordingly.

Please advise or perhaps include the entire project with source for download somewhere. :)
closed with the note: Closing this thread as there was no update from last 2 Weeks or more. Please raise a new query if problem persists.
asked Mar 12, 2015 in App42 Cloud API-BaaS by sslee.simon (10 points)
closed Aug 17, 2015 by sushil
Could you please let us know on which language are you working on c++ or delhi? Also please share the device and os version. It will help us replicate the same at our end.

Himanshu Sharma
delphi xe7 update 1 on win 7
andriod sdk platform 4.4.2 (API19 rev 4)
htc one m7 - andriod 4.4.3
(Encountered same error running on Nexus 7)

No issues running the other sample (

Any advice appreciated. Thanks.
Thanks for sharing these details . We will try to replicate this at stated environment and update you with the same. Thanks for having patience.
Himanshu Sharma
Hello Simon,

Have you added the GCM keys into Android settings (AppHQ Management Console >>  Push Notification >> Settings)? Please makes sure you have created the server key from Google developer console and added into AppHQ Management Console. Also are you able to see the list of users under Push Notification >> User tab. It will help us to debug the same at our end.

Himanshu Sharma

In ‘App42Provider1’ component properties in Delphi, I fill in -
GCMAppID (Google Dev console's Proj No.),
Admin Key, APIKey, SecretKey (from AppHQ Mgt Console >> App Mgr >> App Key) and UserName = ‘testuser’

There is another component called PushEvents1 where its Provider = ‘App42Provider1’

I have created a user (UserName = ‘testuser’) in AppHQ Mgt Console >> Business Service Manager >> User Service >> User

Under AppHQ Mgt Console >> Push Nitification >> Settings >> Andriod Settings, there is one record containing my Push Key = ‘AlzaSyCZ…’ with Provider = ‘GCM’

However, in AppHQ Mgt Console >> Push Notification >> Users, there are no users listed.
It says ‘No push device subscribe for your App user yet’
Am I supposed to see a list of user names here?
Hello Simon,

Thanks for sharing the info, we are looking into it. Will update you very soon on this. Thanks for your patience.
Himanshu Sharma
I tried with a different user and got this:-

Device Token Received

Device Token Request Failed
{"app42Fault":{"httpErrorCode":404,"appErrorCode":2600,"message":"Not Found","details":"Document by the ID'550e7254...' does not exist."}}

Please advise..
Have you create the user from signUp method of Xe7 SDK, not from AppHQ console.
If not then you have to create the user from signUp method, which is available in the sample downloaded with SDK.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on