Unity 5.1.1 breaks on importing "AppWarpS2UnityWP8_1.0.8.dll".

0 votes

When I imported "AppWarpS2UnityWP8_1.0.8.dll" in my project I got following eror please suggest the next steps to go ahead to solve the problem.

Unhandled Exception: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at Mono.CSharp.RootNamespace.ComputeNamespaces (System.Reflection.Assembly assembly, System.Type extensionType) [0x00000] in <filename unknown>:0 
  at Mono.CSharp.RootNamespace.ComputeNamespace (Mono.CSharp.CompilerContext ctx, System.Type extensionType) [0x00000] in <filename unknown>:0 
  at Mono.CSharp.GlobalRootNamespace.ComputeNamespaces (Mono.CSharp.CompilerContext ctx) [0x00000] in <filename unknown>:0 
  at Mono.CSharp.Driver.LoadReferences () [0x00000] in <filename unknown>:0 
  at Mono.CSharp.Driver.Compile () [0x00000] in <filename unknown>:0 
  at Mono.CSharp.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0 
asked Jul 20, 2015 in AppWarpS2 by devang024 (15 points)
recategorized Aug 13, 2015 by sushil

1 Answer

0 votes
Hi Devang,

This error is associated with MonoDevelop and there might be some possible causes for the same, and the most common cause for this is missing System.Web.dll in C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.5 directory.

Also, are you getting this error on dll import or when you Build your game?

And please make sure that you placed the dll under the 'Assets/Plugins/WP8/' folder.

Again, Are you using some other DLLs in your project?

You could also do reimporting assets from Assets>Reimoprt All, if it helps (do this after making your project back-up).

If this issues countinues, feel free to contact us.


Thanks & Regards

Sumit Balodi
answered Jul 20, 2015 by sumit.balodi (40 points)
Sorry for late comment, was busy on other stuff

Anyway, I am getting this error when I try to build to Windows Phone 8, and Yes I have placed associated DLL file in  'Assets/Plugins/WP8/' location

I Have Also checked for the System.web.dll file in the place you mentioned, and its there already, more over I am using Windows 8 and Unity 5.1.2(64 Bit version)

Also tried to reImporting the assets, moreover I also upgraded to Unity 5.1.2 (If its helpful in any way)

But still I am getting the same error messsage

We've actually updated our SDK, but I think the Viking sample was built from our older SDK. Please check out latest sample along with the new SDK from here...


Set port number as 12346.
If you face any further problems building to WP8, feel free to ask.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com