Breakdowns with push notifications (iOS)

0 votes

I started using App42 2 days ago but have already noticed that there are breakdowns with push notifications:

I am testing pushes to channels. 1) When I send them from the website it usually receives the first push, but after it can miss 3 pushes in a row. 2) When I send push from device it usually do not serve push until i send at least 1 from web. Then it also can miss 3 in a row or deliver 2 in a row.

Connection is good. I also receive success logs from device but i do not get push on other devices. What could be the reason of these breakdowns?

These is the log of the push which wasn't sent/delivered/received:


2015-11-27 23:40:24.759 app[7254:218001] Response={"app42":{"response":{"success":true,"push":{"message":{"alert":"textlalala","dataEncoding":"true","badge":"1","sound":"default"},"channels":{"channel":{"channelName":"app1"}}}}}}

asked Nov 27, 2015 in App42 Cloud API-BaaS by aleksandrov.vasilii (11 points)
edited Nov 27, 2015 by aleksandrov.vasilii

1 Answer

+1 vote

Hi Aleksandrov,

I tried both the cases at my end and it is working fine. Can you please provide following details so that we can replicate the same:

1. Is it coming frequently or random?

2. Can you share the log of the push which is getting delivered.

3. Also can you check and share the push logs in the AppHQ Console for the push which is not getting delivered.

P.S.: To check the push logs in AppHQ, login to AppHQ->Select Unified Notification -> Push -> Logs. If logs are not there then please enable Push Log State from AppSettings.


answered Nov 28, 2015 by rajeev.etc (1,660 points)
1. Totally random. Right now I opened my SendPushViewController. The first push wasn't sent/delivered/received. 30 seconds later, staying in the same viewController without any changes, i sent second push, which was successfully done!

2. The log of this "second" push, which I've just sent:
Message sent successfully to iOS Devices : No. of devices : 1

3.Log of the "first" push with error:
iOS KeystoreException  : Invalid keystore reference.  File is empty: /mnt/installations/apipaas/apache-tomcat-6.0.35/webapps/ROOT/repository/files/24769/repository/files/25584a18570f20d83b7e8593a965428d295c2be75064c91b4401ed398a044363/19a08e8ab7e58e63a0f8

Thanks in advance
Yesterday I decided to generate new p.12 file and uploaded it to the website. Everything worked perfect util i got another error log:
iOS CommunicationException  : Communication exception:
Thanks for sharing the logs.
We are looking into it and update you as soon as possible.
Looks like there was random package drop between server and APNS gateway
server. Issue has been resolved from our side and we are keeping a close eye
on it for next few days. Requesting you to please check this at your end too
and let us know if you still face any issue.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on