Custom Code Execution Error

0 votes
Hi, Is there any recent changes on the custom code API? My custom codes are not working which had been OK until a few days ago. Is there any recent SDK upgrade, etc?


On local tests, code executes OK with no problem but if I upload it to apphq and run it, I am getting "Something went wrong" error. Also in client side I get "Error:0 Unexpected end of input" problem.
asked Nov 24, 2016 in Java by Tufan (64 points)

2 Answers

0 votes
Hi Tufan,

Apologies for the inconvenience cause.

Could you please help us with more details like when you started getting this exception, is the exception occurring randomly? Have you deployed your custom in recent days?

Please help us with these detail, so that we can provide better support to you.



Himanshu Sharma
answered Nov 25, 2016 by hs00105 (2,005 points)
0 votes

Hi Himanshu,


The problem has been occurring since a few day ago. Also I downloaded sample custom code from github link, and after editing keys upload it to AppHQ. Problem still exists with the error 'somethin went wrong'.

The only time I dont receive the problem is on a few oldest custom codes which may be created by java 1.6. Maybe java sdk version related to this? Also keep in mind that I am using latest Intellij IDEA to package jar.

This problem has downside effect on the application, so could you please take a look at it urgently?  thanks


answered Nov 25, 2016 by Tufan (64 points)
Cloud code don't run from few days. From App and also if I launch it from app42 site.
Hi again,

I also packaged a custom code with another IDE, and even with java 1.6 and 1.7 with still no luck. The problem still exists.

So could you please consider that urgently?
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on