suddenly MyCustomCode build failed

0 votes

today i upload my customcode but suddenly build failed...

error description as follows...

 

[input] skipping input as property jarFileName has already been set.

     [java] Exception in thread "main" com.shephertz.app42.paas.sdk.java.App42Exception: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

     [java] at com.shephertz.app42.paas.sdk.java.customcode.CustomCodeService.deployJarFile(CustomCodeService.java:91)

     [java] at com.myapp.helper.AntHelper.upload(AntHelper.java:22)

     [java] at com.myapp.helper.AntHelper.main(AntHelper.java:30)

     [java] Caused by: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

     [java] at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Alerts.java:174)

     [java] at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Alerts.java:136)

     [java] at com.sun.net.ssl.internal.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:1822)

     [java] at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1004)

     [java] at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1188)

     [java] at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1215)

     [java] at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1199)

     [java] at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:476)

     [java] at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:166)

     [java] at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1031)

     [java] at sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:230)

     [java] at com.shephertz.app42.paas.sdk.java.util.Util.multiPartRequest(Util.java:241)

     [java] at com.shephertz.app42.paas.sdk.java.customcode.CustomCodeService.deployJarFile(CustomCodeService.java:84)

p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #000000; background-color: #ffffff} span.s1 {font-variant-ligatures: no-common-ligatures} span.Apple-tab-span {white-space:pre}

     [java] ... 2 more

 

i roll back before customcode but still build faield...

 

something wrong with my ssl? or custom code version? 

 

asked Dec 3, 2016 in Announcements by exceeduniverse (10 points)

1 Answer

0 votes
Hi,

Could you please deploy the custom code through AppHQ Management Console and let us know if you still face any issue.

 

Regards,

Himanshu Sharma
answered Dec 5, 2016 by hs00105 (1,935 points)
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com
Migrate from Parse to ShepHertz App42
...