Flash UDP not working

0 votes
I am using AppWarp Flash and using the UDP update peers API. I know that UDP is unreliable but so far its never worked for me! I'm not getting onUpdatePeersReceived ever when I send using udp. The same works when I run using the normal tcp update peers API.
asked Feb 21, 2014 in AppWarp by starabc (39 points)

1 Answer

+1 vote
Best answer
Are you running your flash app in a browser? The flash runtime on the browser doesn't support UDP.

Also make sure that you have called initUDP method after connecting successfully to the server. If you call it before connecting - it has no effect. Verify that you are getting onInitUDPDone with a successful result code. Once that is done - it should be OK to send messages over UDP.
answered Feb 21, 2014 by dhruvc (1,099 points)
selected Feb 21, 2014 by starabc
No - I am building a desktop app. I checked the adobe documentation and according to that UDP is supported when building PC applications.
Have you tried the UDP smiley space shooter sample from our dev center? Does that work for you?
Thanks! yes the problem was that I was calling initUDP before connecting to the server. Now it works fine.. Also the UDP demo on your dev center is working fine for me.

Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com