App42 blocks main thread after application becomes active

+1 vote


The app is freezing every time it becomes active. It seems that it synchronizing the data on the main thread and locks it.
Sometimes during this process splash screen from our app is visible, but we have seen random screen from our app instead of splash and it also continues for ~10-20 seconds. (See video -
The worst case is when a user is prompted with any iOS permission (for example 'Camera permission') and after confirming he need to wait ~10-20 seconds before app will become responsible.  (See video -
For testing I've created a new project and have linked and I have the same issue.
Then I've tried to disable all tracking services, but it doesn't help:
    [App42API setOfflineStorage:NO];
    [App42API enableCrashEventHandler:NO];
    [App42API enableAppStateEventTracking:NO];
    [App42API enableAppAliveTracking:NO];
    [App42API enableEventService:NO];
    [App42API enableApp42Trace:NO];
All these issues are very critical for our application and UX and we hope that you can help us to improve the performance.
Thank you!
asked Feb 6, 2017 in iOS by den.dovgan (15 points)

1 Answer

0 votes

I have forwarded this to our development team and will update you ASAP.

Meanwhile, could you please share your sample project in which you are getting this issue? It will help to understand the problem.

answered Feb 7, 2017 by rajeev.etc (1,660 points)
It is a link to the sample project, check please.
Any news with this bug?
I have changed that call from Sync to Async in the SDK. Now it will not block the main thread. Please download the modified SDK from here( ).
Let me know if you have any queries.
Thanks, now it works as we wanted!
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on