[CRITICAL SDK BUG] App42 J2ME 2.1 Returning "0" errorcode with Null exception message

0 votes

I have started using App42 J2ME SDK 2.1 for my mobile game using Libgdx, and for the IOS part, I am using the J2ME SDK.

The problem is, when I try to register or login a user using UserService, it returns error codes "0" for both http and app errorcodes and the exception message is Null. For the Android and Desktop versions which are using the Android  SDK and Java SDK, it works fine.
I tried Java SDK instead of J2ME SDK for the IOS part, but it did not work and  I got the same error as this post (http://forum.shephertz.com/?qa=4921/leaderboards-with-libgdx-robovm)
Many Thanks in advance.
Here is the App42Log for the failure with J2ME: (censored some private information)
UTC Date : 2018-02-26T05:52:11.711Z
 Json String : {"app42":{"user":{"password":"xxxxxx","userName":"sim"}}}
mac alg: SHA-1/HMAC
dig alg: SHA-1
key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
message: apiKeyxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxbody{"app42":{"user":{"password":"xxxxxx","userName":"sim"}}}timeStamp2018-02-26T05:52:11.711Zversion1.0
unencoded: ��c$�Yj2xܐ�ɖ'� F
sig: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx=
 Setting value :version : 1.0
 QueryString is ?version=1.0&
 QueryString is ?version=1.0&


asked Feb 26, 2018 in Java by ghkdtkdans (20 points)

1 Answer

0 votes

You are getting this problem only in Register and Login API of User service or with other APIs a well?

answered Feb 27, 2018 by rajeev.etc (1,660 points)
I haven't tested with other API calls. So I can only confirm the Login and Register API of User Service at the moment. Is this a known issue?
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com