Collections problem is real: appErrorCode:140, message:UnAuthorized Access, details:Client is not authorized

0 votes

I am also having this problem. It started after I deleted a collection. I can no longer .insertJSONDocument to any *new* collection, only an existing one. I have tried various simple names, such as "test", and nothing works. Also, just like the other poster, I get, "Something went wrong" when I try to create a new collection on the nosql storage AppWarpHQ page.  Using your old UI, I tried doing an "Import Data" with "Add New" collection.  I used your sample JSON from the "Learn More" link to make sure I complied with your format.  Just like for the other poster, it gives an error: "Invalid Request".

Note that I do not get an error when trying to .findDocumentsByQuery on a non-existant collection, only when I try to .insertJSONDocument on a non-existant collection.

'{"app42Fault":{"httpErrorCode":401,"appErrorCode":1401,"message":"UnAuthorized Access","details":"Client is not authorized"}}'

Also note that there was no problem **before** I deleted the collection from the nosql storage AppWarpHQ page.  Importantly, I am still able to .insertJSONDocument on my existing collections, but unable to create new ones.


Here's the code I'm using.  It ***WORKS WITH AN EXISTING COLLETION*** but fails when a non-existant collection is named:


			nosqlSvc.insertJSONDocument(MASTER_DB_NAME, "test", {test:1},
				new UserServiceCallback(
					function(obj:Storage) : void
						log("INSERT OK");
					function(ex:App42Exception) : void
						log("INSERT FAILED", ex.getMessage(), "APP:", ex.getAppErrorCode(), "HTTP:", ex.getHttpErrorCode());



I see a lot of questions in this last week about this same problem.  Please advise, this is obviously not a customer implementation issue.

asked May 10, 2018 in App42PaaS & BPaaS by kustardking (12 points)
edited May 10, 2018 by kustardking

1 Answer

0 votes

Hi Kustardking,

Could you please add me( as collaborator to your app and share the App Name in AppHQ Management Console?

It will help us in investigating this problem.

P.S. To add collaborator, go to App Manager -> Collaborator -> Add Collaborator and provide above email address.


answered May 11, 2018 by rajeev.etc (1,660 points)
I've added as a collaborator.  The app name is ChopSuey.
Hi Rajeev - I see that it is working again, and that someone made a test collection, "accounts1".  Thanks for the help.  What was the problem?
Yes, there was some problem with the collection creation which we have fixed.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on