Push notification Android [ errorCode=MismatchSenderId ]

0 votes

Hi, I tried to make https://github.com/shephertz/App42-Android-Push-Sample/archive/master.zip this work but I failed

First of all, I set up a server key on GCM (Key for server apps (with IP locking)

Secondly, I added the key into the Android Settings tab

Thirdly, inside the code, I changed the secret key, the api key

I'm not sure what to put in setLoggedInUser("dani") ; but I used a regular name or whatever

as for Util.registerWithApp42("841437349596"); I used the project id from GCM


After all this, when I try to send a push from the console, it doesnt work and the log says [ errorCode=MismatchSenderId ]

I can see the user registered in the console, with username, deviceid, ect but it won't send the push.

Please help !!!


LE: For all those who wanna be sure I did everything:

closed with the note: Solved
asked Jul 10, 2014 in App42 Cloud API-BaaS by daniel.dinu91 (15 points)
closed Jul 12, 2014 by daniel.dinu91
looks like some issue on key side. We have updated your smaple with our keys here http://cdn.shephertz.com/repository/files/e86da38e4f4363bcbce74c431ca10173bf452e47285893e8d2044bb3913b7153/e5f0028f3c526b319a0897a011d9dc8db30637d3/Working_Sample.zip and it is working fine. Also, If you have two apps in AppHQ make sure that you have uploaded GCM keys to correct app used for push notification.
I tried running the sample you gave me on my device, and then I changed the             App42API.setLoggedInUser("dani") ; to another username and ran it on another device. Push didn't work.. no notification was coming through. Then I tried making a new App42 account and a new google developer account, a new project in the developer console, a new app in the App42 console, changed the info in the sample you provided me, same error.. mismatch sender id... I am getting pretty desperate here and short on time.. please help me.. if you want, I can provide with Teamviewer credentials or skype sharescreen or anything so you can see for yourself all this. or if you think of any other way, I'm open
LE: After poking around with another device, I concluded that it's my phone's fault and I will try to fully erase it and restore to factory settings and see how it goes. I'll keep you posted !
yes, after resetting to factory setings, push works.. I'm sorry I wasted your time, thank you very much for the help and I appreciate your time. This gives me a great impression about your company !
No Problem Deniel. I am glad it worked for you. Would request you to close this question if it worked for you.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com