Unity - Upload Service - UploadFile returns NullReferenceException

0 votes

I'm trying to implement a file uploader in Unity3d (v. 4.5.1f3, Windows/Mac/Linux Standalone Platform). I tried to upload one asset (< 1Mb) and it was successful. But when i tried to upload a bigger file (approx 9Mb). I received the following error after waiting a while:


NullReferenceException: Object reference not set to an instance of an object

com.shephertz.app42.paas.sdk.csharp.connection.RESTConnectorWWW+<executeMultipart>d__12.MoveNext ()

com.shephertz.app42.paas.sdk.csharp.connection.RESTConnectorWWW+<WaitForMultipart>d__f.MoveNext ()
Is the error because of the size of the file that I wanted to upload? If so, is there any way to make it work? And is there a file size limit for each uploaded file? Thanks
closed with the note: Closing this thread as there was no update from last 2 Weeks or more. Please raise a new query if problem persists.
asked Jul 17, 2014 in App42 Cloud API-BaaS by jonathan.cortes (56 points)
closed Sep 17, 2014 by sushil
We are trying to replicate this on our side and let you know if there is something wrong with this. As well, can you share the details that in which platform you are getting this error, type of file like image,audio or video etc and sdk version.
Our current OS platform is Windows 8. We're currently using App42_Unity3D_SDK_2.9.dll, the files uploaded were asset bundle files (*.unity3d). We used BuildPipeline.BuildAssetBundle() to create the asset bundles, using the following build options:

BuildAssetBundleOptions.CollectDependencies | BuildAssetBundleOptions.CompleteAssets |

We used the UncompressedAssetBundle option since this option is required for loading from disk. And the build target parameter is BuildTarget.StandaloneWindows64.

For the uploadfile() call, we used UploadFileType.OTHER for the file type
We will look forward to your issue. I think this occurs when client is timeout on large file. We are trying to fix this problem. May be new release is updated on Monday.
It seems some issue on our gateway while dealing with file greater than few MBs. We are working on this and fix would be available in current week only.
Any updates on this? thanks
Hi Jonathan,
Please check. This issue is resolved from our side.

Thanks for patience.
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com