End of file in AS3 API

0 votes
Hi guys!

I'm just fighting with this cruel error:

Error: Error #2030: End of file was encountered.
at flash.utils::ByteArray/readBytes()
at com.shephertz.appwarp.messages::Notify$/buildNotify()[F:\Suyash\Shephertz\GitHub\AppWarpAS3\AppWarpLib\src\com\shephertz\appwarp\messages\Notify.as:37]
at com.shephertz.appwarp::WarpClient/handleMessage()[F:\Suyash\Shephertz\GitHub\AppWarpAS3\AppWarpLib\src\com\shephertz\appwarp\WarpClient.as:358]
at com.shephertz.appwarp::WarpClient/socketCallback()[F:\Suyash\Shephertz\GitHub\AppWarpAS3\AppWarpLib\src\com\shephertz\appwarp\WarpClient.as:298]
at com.shephertz.appwarp.utility::WarpSocket/socketData()[F:\Suyash\Shephertz\GitHub\AppWarpAS3\AppWarpLib\src\com\shephertz\appwarp\utility\WarpSocket.as:63]


I can't say much about this. It's not happening very often but my Game crashes instantly after this error. There is no way to handle this error, because its happening in the in the AppWarpAS3 lib. Does anyone has seen this before? Is there any way to resolve or handle the error?

Best regards,

asked Aug 20, 2014 in AppWarp by r.kenzler (26 points)

1 Answer

+1 vote
Best answer
Hey Rico,

I guess you are using an older version of our SDK. Please download the latest version of AS3 SDK from here https://github.com/shephertz/AppWarpAS3Library/tree/master/V_1.6.2

This bug has already been solved in our latest SDK. If you still get the error, please let us know.

answered Aug 21, 2014 by Suyash Mohan (900 points)
selected Aug 21, 2014 by r.kenzler
Thank you for your answer! I just downloaded the new version. I'm not sure which version I used so far. I will tell you, if the error appears again.

Btw: The support in this forum is amazing :)
Download Widgets
Welcome to ShepHertz Product line forum, where you can ask questions and receive answers from the community. You can also reach out to us on support@shephertz.com